div.c and other questions

Brian Gladman brg at gladman.plus.com
Tue Sep 28 10:39:12 CEST 2004

Vincent Lefevre wrote:

> On 2004-09-27 14:05:56 -0400, Mike Loehr wrote:
>>Here's the modified div.c, no big deal really, just a search and
>>replace of 'near' with 'mpfr_near'.
> It is not a good idea to use the "mpfr_" prefix for the local variable
> names. Anyway, there are other possible names, and "tonearest" would be
> a better name than "near" since it indicates the "rounding to nearest"
> mode.

In my view the name change is trivial and is by far the most sensible 
solution since it is unsound to leave things in place that might cause 
problems for some users when such an easy solution is available.

Moreover, I feel sure that Mike Loehr doesn't care what this name is 
provided that it avoids the problem - if the MPFR team feel that 
'tonearest' is better than 'mpfr_near' and 'near' let it be thus :-)

    Brian Gladman

More information about the gmp-discuss mailing list