div.c and other questions

Vincent Lefevre vincent at vinc17.org
Tue Sep 28 09:52:30 CEST 2004

On 2004-09-27 14:05:56 -0400, Mike Loehr wrote:
> Here's the modified div.c, no big deal really, just a search and
> replace of 'near' with 'mpfr_near'.

It is not a good idea to use the "mpfr_" prefix for the local variable
names. Anyway, there are other possible names, and "tonearest" would be
a better name than "near" since it indicates the "rounding to nearest"

Vincent Lefèvre <vincent at vinc17.org> - Web: <http://www.vinc17.org/>
100% accessible validated (X)HTML - Blog: <http://www.vinc17.org/blog/>
Work: CR INRIA - computer arithmetic / SPACES project at LORIA

More information about the gmp-discuss mailing list