Issue with GMP static linkage (and bundle)

Torbjörn Granlund tg at
Sat Sep 30 12:51:09 UTC 2017

Daniele Ghisi <danieleghisi at> writes:

  I need to link GMP statically to a project (written in C).
Which version of GMP?

  I can't seem to do it if the Mach-O Type of my target is set to "Bundle".


WHat does "type of target" mean in this context?

  No issues when it is set to "executable" or "static library".

Weird things those apples.  Why don't you avoid "Bundle" if that doesn't

  No issues when I use dynamic linkage either (with -lgmp)
Perhaps something to consider, then?

  I am on OS X 10.10.5, Xcode 7.2
  I have tried to install GMP manually or with homebrew, in both cases I
  still get the issue.

Are you saying that your original problem is with somebody else's
compile?  Then perhaps talk to them?  The GMP team cannot unravel issues
with package compiles later causing user problems.

If you compile GMP yourself (which is what I assume you mean by "install
GMP manually") then the problems persists, IIUC.  Are you sure you link
to your own compiled version, then?  And again, which GMP version did
you compile?

Please encrypt, key id 0xC8601622

More information about the gmp-discuss mailing list