Is there a separate Windows package for GNUMP?

Akhil Anilkumar Kalathungal akhil.cet at
Mon Mar 25 15:28:31 CET 2013


I realized that it was due to my dumbness.
I downloaded the 5.1.1 version and extracted in Windows 7 and tried all the
commands from cygwin.
Seems to be working now.
May be earlier I copied a pre compiled version from Ubuntu to Windows. I
apologize for the inconvenience.

Thank You,

On Mon, Mar 25, 2013 at 7:15 AM, Torbjorn Granlund <tg at> wrote:

> Akhil Anilkumar Kalathungal <akhil.cet at> writes:
>   I think I cornered the issue here:
>   Initially I tried to run the ./configure command from the cygwin
> terminal which
>   created the Makefile and the executable
>   gen-fac_ui.
> That will not compile anything, and thus not create gen-fac_ui.
>   However the file gen-fac_ui is an ELF 32-bit executable created for
> GNU/Linux
>   2.6.15 and not for Windows.
>   Akhil at Akhil-PC /cygdrive/c/GNU_MP_Library/gmp-5.0.5
>   $ file ./gen-fac_ui
>   ./gen-fac_ui: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV),
>   dynamically linked (uses shared libs), for GNU/Linux 2.6.15,
> BuildID[sha1]=
>   0x9046aa5e70c378323826c46f3b0cdbdd91429a4b, not stripped
> You must have created that file at an earlier point, presumably when
> compiling GMP from the same sources on a GNU/Linux system.
>   For the above reason, I have to explicitly force a .exe extension with
> the
>   executable while I try to run that.
>   Like ./gen-fac_ui.exe
> This does not make sense to me.  Unless there is some GNU/Linux
> emulation built in to Cygwin.
> I presume compiling GMP will work for you just like for everyone else
> if you avoid mixing compiles from incompatible systems.  Further
> instructions on how to compile GMP can be found in the manual.
> --
> Torbjörn

More information about the gmp-discuss mailing list