Is there a separate Windows package for GNUMP?

Akhil Anilkumar Kalathungal akhil.cet at
Sun Mar 24 20:49:29 CET 2013

Hello Torbjorn,

I hope my build environment is not corrupted, since I had been doing some
other cygwin projects as well.
Please see my attached screenshot for a cygwin environment which is a
makefile project. And I am able
to run the output Program which is ./outputProgram.exe

Now please find the attached screenshot (GNUMP_test_one.jpg) which is the
scenario now.
Interesting fact is, the command  "./gen-fac_ui 32 0" does not run and it
displays the 'cannot execute' message.
However the command ./gen-fac_ui.exe 32 0 runs and the output is displayed
as shown in the screenshot.

So I thought the issue is with the '.exe' extension and I tried to fix that
by modifying the macro "EXEEXT_FOR_BUILD"
in the Makefile but it is not helping here.
Looks like the 'make' command that I run does not even look for a Makefile
in the path 'C:\GNU_MP_Library\gmp-5.0.5' and it runs on its own. (I tested
it by deleting the Makefile from the directory and tried a 'make' command
from the cygwin terminal. It runs, with the error build message! )

Do you have any thoughts in this, please advice.

Thank You,
Graduate Student
U Cincinnati

On Sun, Mar 24, 2013 at 3:07 PM, Torbjorn Granlund <tg at> wrote:

> It seems your compiler environment is broken.
> Have you tried gcc hello.c and then tried to execute the result (either
> as ./a or ./a.exe)?
> Note also that GMP 5.1 will give much better performance for the 64-bit
> ABI on Windoze, compared to GMP 5.0.5.
> --
> Torbjörn
-------------- next part --------------
A non-text attachment was scrubbed...
Name: GNUMP_test.jpg
Type: image/jpeg
Size: 262752 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: GNUMP_test_one.jpg
Type: image/jpeg
Size: 350673 bytes
Desc: not available
URL: <>

More information about the gmp-discuss mailing list