SOLVED: gmp 4.2.2 error: hidden symbol __clz_tab' is referenced by DSO

Thomas Rudolph dk3dua at
Thu Sep 20 16:15:29 CEST 2007

Hello again,

sorry, I'm in the wrong group.
It's libcrypto who's using that wrong __clz_tab symbol.
If  I take librcrypto  from the newest openssl-release instead of 
libcrypro  from uClibc it's all fine.


Thomas Rudolph schrieb:
> Hello,
> I always get :
> /mips-linux-uclibc/bin/ld: spi: hidden symbol `__clz_tab' in 
> /opt/uclibc_mips-toolchain/gcc-3.3.6/toolchain_mips/bin-ccache/../lib/gcc-lib/mips-linux-uclibc/3.3.6/libgcc.a(_clz.oS) 
> is referenced by DSO
> when I try to link libgmp 4.2.2 (was the same with 4.2.1. too) to 
> openswan, in a mips32 cross-compile-environment.
> I configured with ./configure --host=mips-linux --build=i386-linux 
> --disable-fft ,and
> tried autoreconf etc. pp., also to compile without assembler parts.
> libgmp always compiles without problems, I can build shared and static 
> lib, but openswan-2 who needs libgmp ends with the error message above.
> Can anyone please give me a hint how to solve the problem?
> Thanks and regards
> Thomas from Dresden/Germany
> _______________________________________________
> gmp-discuss mailing list
> gmp-discuss at

More information about the gmp-discuss mailing list