trying to get gmp running Karlkneile at
Wed Aug 24 04:06:52 CEST 2005

I am having problems getting gmp up and running.  The description of  my 
problem is both below and in the attached file.  The attachment is a  wordpad text 
file. I'm not certain which is the preferred mode in this  forum.  I'm sure I 
made a simple error, but I'm at a loss what to try  next.
I am trying to get gmp running on my system.
cygwin ver 2.457.2.2 with windows XP.
gcc was downloaded and installed thru cygwin
it appears to be working  OK
gmp was downloaded from swox
I didn't find it at cygwin; is it  there?
gmp was installed using ./configure
followed by a make
make  check gave all passes
I tried the following program  "progname"
  #include <stdio.h>
#include <gmp.h>
mpz_t  n;
c++   -I/gmp-4.1.4   progname
I had to use the -I option for c++ to find the gmp.h file
Could I  have installed it differently to avoid this?
The above resulted the error: undefined reference to '___gmpz_int'
I  tried using -L/ without any change
What am I doing wrong?
Is there a better way to install gmp?
I am not  a systems person; just a c++ user that would like to have  gmp.

-------------- next part --------------
An HTML attachment was scrubbed...
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: gmp.txt

More information about the gmp-discuss mailing list