bodrato at mail.dm.unipi.it
Mon Jan 31 23:01:25 CET 2022
Il Mer, 26 Gennaio 2022 7:53 am, Marco Bodrato ha scritto:
> Il 2022-01-24 10:04 Torbjörn Granlund ha scritto:
>> Marc Glisse <marc.glisse at inria.fr> writes:
>> What would you think of adding mpq_mul_ui, mpq_div_ui, mpq_ui_div,
>> also the _z versions?
>> That would make sense to me.
> I agree too, I just remember an observation about the naming convention:
...but actually only the _singleui versions of _mul_ and _div_ are really
useful. Moreover, to handle the _twouis version, the need to check if the
given ui/ui fraction is normalised arises.
Shall we start with the _z flavours?
On the other side, it might be useful to have functions to _add_, or _sub_
small fractions: eg. +1/2, -4/3.
More information about the gmp-devel