Torbjorn Granlund tg at
Sun Mar 3 19:15:08 CET 2013

nisse at (Niels Möller) writes:

  Torbjorn Granlund <tg at> writes:
  >   And this. (I think I'd prefer
  >     mp_limb_t
  >     mpn_cnd_add_n (mp_limb_t cnd, mp_ptr rp, mp_srcptr ap, mp_srcptr bp, mp_size_t n)
  >   but that's a minor detail, and view the cnd_-prefix as a family of
  >   functions. Some other potential members are mpn_cnd_copy, mpn_cnd_neg
  >   and mpn_cnd_swap, see
  >   for one application).
  > I agree that would be a good naming cleanup.  Will you do the honours?
  I'll put it on my mental TODO list. You did notice that I moved the
  condition to be the first argument? Will require minor changes to the
  assembly implementations.
I didn't notice that.  Ahum.  That makes the change much harder, of


More information about the gmp-devel mailing list