mpn_cnd_add_n (was: Re: GMP symbol naming (and the history thereof)?)

Niels Möller nisse at
Sun Mar 3 18:57:49 CET 2013

Torbjorn Granlund <tg at> writes:

>   And this. (I think I'd prefer
>     mp_limb_t
>     mpn_cnd_add_n (mp_limb_t cnd, mp_ptr rp, mp_srcptr ap, mp_srcptr bp, mp_size_t n)
>   but that's a minor detail, and view the cnd_-prefix as a family of
>   functions. Some other potential members are mpn_cnd_copy, mpn_cnd_neg
>   and mpn_cnd_swap, see
>   for one application).
> I agree that would be a good naming cleanup.  Will you do the honours?

I'll put it on my mental TODO list. You did notice that I moved the
condition to be the first argument? Will require minor changes to the
assembly implementations.


Niels Möller. PGP-encrypted email is preferred. Keyid C0B98E26.
Internet email is subject to wholesale government surveillance.

More information about the gmp-devel mailing list