TODO for 5.2

Torbjorn Granlund tg at
Sun Dec 29 16:39:59 UTC 2013

nisse at (Niels Möller) writes:

  I just put the declarations together with the other mpn_sec_* functions.
  I think it makes sense to make mpn_sec_div_*, mpn_sec_minvert and
  mpn_sec_powm public together. Does mpn_sec_powm need more work (besides
  the rename) before made public?
I made it public the other day.  I think its interface need no more
work.  Please pull.

  Also about naming, I noticed the inconsistency between mpz_invert and
  mpn_invert, which do very different things.

Indeed.  But only mpz_invert is public.  (It would have been nice to
have had some "mod" stuck in there.)

  If/when we add an mpz function corresponding to mpn_sec_minvert, I
  guess that would be named mpz_sec_invert?
I suppose.  We should probably already now make mpz_sec_powm and
mpz_powm_sec be aliases.


More information about the gmp-devel mailing list