Naming convention for functions with a single operand.

bodrato at bodrato at
Thu Dec 24 14:24:45 CET 2009


I have some doubt about the naming convention of mpn_ functions with a
single operand.
Some of them have the "_n" suffix, probably because "all the operands have
the same size", e.g. mpn_com_n, mpn_neg_n and mpn_sqr_n.
Some other does not have any suffix, probably because "the size of all
operands must be specified", e.g. mpn_invert, mpn_?shift, mpn_zero.

I prefer the second style, without any suffix... I think we should decide,
before documenting and giving public access to mpn_sqr_n and mpn_zero...

Have merry Christmas!


More information about the gmp-devel mailing list