Building GMP 6.0 for Ivy Bridge

Victor Shoup shoup at
Fri Oct 2 12:56:18 UTC 2015

Was there some other code I was supposed to compile?
I just stripped out the program you indicated and tried compiling that by itself,
and got the undefined reference.

Also, from the information I gave you on my system,
does --build=coreisbr-unknown-linux-gnu seem like
the right option?  Again, lscpu gives:

Model name:            Intel(R) Xeon(R) CPU E5-2680 v2 @ 2.80GHz

And that is definitely an ivy bridge.

On Oct 2, 2015, at 8:44 AM, Victor Shoup wrote:

> Linker fails:
> hhhh.c:(.text+0x31): undefined reference to `cpuid'
> On Oct 2, 2015, at 2:24 AM, Marc Glisse wrote:
>> On Thu, 1 Oct 2015, Victor Shoup wrote:
>>> I tried the latest daily snapshot and ran "./configure".
>>> I get:
>>> Host type:         x86_64-unknown-linux-gnu
>> Hmm, I would have expected config.guess to return ivybridge-unknown-linux-gnu.
>>> So I guess GMP's "automagic" is not working as well as one would hope.
>>> Let me know if there is some config patch you want me to try.
>> In config.guess, if you look for the string ivybridge, you'll find a C program that determines your processor type from variables family, model, cpuid_64bit, cpu_64bit, cpu_avx, etc. It would help if you could print those variables and send us the result.
>> By the way, I hope you are not using any virtualization / emulation? Those tend to mess with CPU identification.
>> -- 
>> Marc Glisse
> _______________________________________________
> gmp-discuss mailing list
> gmp-discuss at

More information about the gmp-discuss mailing list