6.0.0a -Fails to build on my powerpc box (debian wheezy)

sisyphus1 at optusnet.com.au sisyphus1 at optusnet.com.au
Wed Mar 26 09:35:59 UTC 2014


No problems with 5.1.3.

For 6.0.0, I ran simply './configure' (which is the same as I ran for 

But, with 6.0.0, 'make' then fails as follows:

libtool: compile:  ../mpn/m4-ccas --m4=m4 
gcc -std=gnu99 -c -DHAVE_CONFIG_H -I. -I.. -D__GMP_WITHIN_GMP -I.. -DOPERATION_gcd_1 
 -m64 -O3 gcd_1.asm  -fPIC -DPIC -o .libs/gcd_1.o
gcc -std=gnu99 -c -DHAVE_CONFIG_H -I. -I.. -D__GMP_WITHIN_GMP -I.. -DOPERATION_gcd_1 
 -m64 -O3 tmp-gcd_1.s -fPIC -DPIC -o .libs/gcd_1.o
tmp-gcd_1.s: Assembler messages:
tmp-gcd_1.s:94: Error: unsupported relocation against 
make[2]: *** [gcd_1.lo] Error 1

In case it's relevant, my config.log (gzipped) for the failing build is 

My gcc compiler is the same one that built 5.1.3 without problem:
gcc version 4.6.3 (Debian 4.6.3-14)

No problems on Ubuntu-12.04 LTS using:
gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: config-6.0.0a.log.gz
Type: application/x-gzip
Size: 22130 bytes
Desc: not available
URL: <https://gmplib.org/list-archives/gmp-discuss/attachments/20140326/264c9284/attachment-0001.bin>

More information about the gmp-discuss mailing list