Discrepancy in measuring performance?

William E. Skeith III wes_zilla at yahoo.com
Tue Apr 3 05:10:36 CEST 2012

*Update*:  I performed the same sequence of steps on my desktop computer
at work (which has an essentially identical software setup) and
everything worked the way I expected: my test code gave the very same
results as what ./speed produces.  So I guess the method is not totally
off, but the problem is something specific to my laptop.

On the laptop, I tried copying the libraries themselves to /usr/lib/ and
relinking my test code.  No difference.

I have now rebuilt the libraries from scratch on my laptop, using the
very same options (that worked) on my desktop, but nothing has changed.
The results of my test program are still off by a factor of almost 2
from what ./speed shows.

Maybe I should just let this go??  It isn't like my laptop was a high
performance machine anyway, but this is frustrating nevertheless.

Out of curiosity, does anyone know what magic was done in the speed
program to avoid whatever issue my program seems to have?  I'll take a
closer look at the source if no one knows offhand.

Thanks again for your time on this!


p.s. For whatever it is worth, my machine at work is also a core 2, but
it has two quad cores.  I don't see explaining anything though.

More information about the gmp-discuss mailing list