mp_ptr and mp_srcptr

Vincent Lefevre vincent at
Fri Feb 4 08:40:23 CET 2011

On 2011-02-03 21:34:42 +0100, Paul Zimmermann wrote:
> thank you Marco and Torbjörn for your answers. Then I suggest we define in
> #define mpfr_mp_ptr    mp_limb_t*
> #define mpfr_mp_srcptr const mp_limb_t*

Yes, but with a typedef, this would be cleaner IMHO.

I had suggested mpfr_limb_ptr instead of mpfr_mp_ptr (it is 2 character
longer, but I find it more clear).

Vincent Lefèvre <vincent at> - Web: <>
100% accessible validated (X)HTML - Blog: <>
Work: CR INRIA - computer arithmetic / Arénaire project (LIP, ENS-Lyon)

More information about the gmp-discuss mailing list