Question on configuring...

David Cleaver wraithx at
Sat Mar 22 03:23:07 CET 2008


I'm trying to configure GMP in, what may or may not be, a unique environment. 
I'm using Windows XP 64-bit edition, an msys/mingw environment, but instead of 
using the 32-bit msys/mingw compilers, I'm using the mingw-w64 compiling tools 
to try and build 64-bit GMP.  I'm running into trouble and was wondering if 
anyone could help?

I'm trying to run configure like so:
./configure CFLAGS=-O0 --host=x86_64-pc-mingw32 ABI=64

I have to use -O0 because none of the other optimizations were working (probably 
a problem with the version/build of gcc I'm using).

I got down to the test (and error):
checking size of mp_limb_t... 4
configure: error: Oops, mp_limb_t is 32 bits, but the assembler code
in this configuration expects 64 bits.
You appear to have set $CFLAGS, perhaps you also need to tell GMP the
intended ABI, see "ABI and ISA" in the manual.

Now, I read the manual, and got from it that I should include ABI=64 (as shown 
above) but adding this option didn't help, I just get the same error.

Has anyone tried this before?  Does anyone see what I might be doing wrong?  Is 
any additional information needed to help diagnose this problem?  Thanks for 
your time.

-David C.

More information about the gmp-discuss mailing list