The GMP-4.2.2 and Chudnovsky.c problem !!!

Jason Lin chyn0610 at
Mon Dec 10 14:51:09 CET 2007

I got a strange problem !
Several weeks ago I compiled and installed the
GMP-4.2.2 on both XP with DEV-CPP and linux(Slackware
8.1) for a try. and I also compiled the PI calculation
program Chudnovsky.c , it worked correctly on both
system (it could calculate PI to 50 million digits). 

 Yesterday the chudnovsky program "crashed" when ran
it. Even recompiled, it still crashed. both the XP and
Linux crashed, on XP it give an error MSG window, on
Linux it give an message of "Floating point exception

 I wonder at this strange problem ! It worked fine
before and I didn't change anything(system ,hardware ,
gmp library ,....) 

 after some debuging effort on the chudnovsky source
code I find the problem is on line #140 mpf_ui_div(t1,
1, x);  It cause the runtime error ! it is a function
of the GMP and i can't trace into it. 

 Is there anyone got the same problem ? How to fix it

 thanks in advance
Jason Lin.


More information about the gmp-discuss mailing list