gmp-4.2.1 with enable-cxx=detect doesn't build with fresh MinGW

Sisyphus sisyphus1 at
Tue Sep 19 05:27:51 CEST 2006

----- Original Message ----- 
From: "Wolfgang Boiger" <Wolfgang.Boiger at>
> I'm new to gmp, so I don't know
> - if this is the right mailing list
> - the information provided is usefull

I think the gmp-discuss mailing list would be better. You might also want ot
submit a bug report. See

> Does anyone know why these errors occur?

I certainly don't - but I haven't tried very hard to work it out. I get the
same error as you when having configured with '--enable-cxx=detect'.
And, like you, it works fine when I configure with '--enable-cxx'.

You might start with a diff of the 2 config.log files. There are some
differences there that may lead to an understanding of the problem.

I guess the important thing is that you *can* build the cpp library -
unthreaded, anyway.

I don't think you want to '--enable-mpfr'. I think that was a switch you
enabled in the past to build the mpfr implementation that shipped with the
GMP source. That particular mpfr implementation was buggy (so it wasn't a
good idea to build it anyway) and it's no longer included with the GMP
source. It should therefore have no effect on your build, but try removing
it anyway - perhaps it is messing something up.

To build mpfr, I have always first built GMP, then downloaded the mpfr
source from (check for bugs and patches on
that page, too), and then build according to the documentation at . (It has always been
straightforward, though I usually build only static libs ... and no cpp.)


More information about the gmp-discuss mailing list