Installing GNU MP 4.1.3 on a INTEL pentium 4 with a MINGW gcc compiler port

Sisyphus kalinabears at
Sun May 23 12:32:09 CEST 2004

Louis Godio wrote:
> After reading the GNU MP 4.1.3 manual, I'm unable to figure out how to
> install MP 4.1.3. If anyone has solved this problem, I'd appeciate any
> advice or details. 

I assume you're running MS Win32.

1. Install MingW
2. Install the MSYS shell.
3. In the MSYS shell:
    cd to where you've unpacked the GMP source.
    Run './configure --disable-static --enable-shared'.
    Run 'make'.

(Last time I tried, 'make check' and 'make install' did not function 

In the '.libs' folder you'll find the file 'libgmp-3.dll'. Move it to a 
folder that's in your path. In the same folder you'll find the file 
'libgmp.dll.a'. Rename it to 'libgmp.a' and move it to where your 
compiler can find it.

Also move 'gmp.h' to where your compiler will find it.

Let us know at which point(s) in the above procedure you strike trouble.


Any emails containing attachments will be deleted from my ISP's mail
server before I even get to see them. If you wish to email me an
attachment, please provide advance warning so that I can make the
necessary arrangements.

More information about the gmp-discuss mailing list