building DLL with MinGW fails

Sisyphus kalinabears at
Sat May 1 03:12:21 CEST 2004

Radu Ursu wrote:

> Hi,
> Thank you for your responce. I used gmp-4.3.1. Do you use the same gmp 
> version?
> As far as I am concerned, I make no difference between MSYS and cygwin 
> as long as I am using MinGW compiler and not gcc that comes with cygwin.
> I suspect a problem with the gmp. I forgot to say that the static build 
> works fine.

I was using 4.1.2, but I've just built 4.1.3 (in the MSYS shell with 
MinGW) and have so far found no problem with it - except that 'make 
test' is still not working.

I ran ./configure --disable-static --enable-shared --enable-mpfr
followed by 'make', then built the '.lib' files, copied the files I 
needed to the appropriate location, etc.

What is the exact problem you are finding ?


Any emails containing attachments will be deleted from my ISP's mail 
server before I even get to see them. If you wish to email me an 
attachment, please provide advance warning so that I can make the 
necessary arrangements.

More information about the gmp-discuss mailing list