compiling gmp-4.1.2 with msys error: libtool: link: `mp_bases.lo' is not a valid libtool object

DH crazyinsomniac at
Thu Mar 18 07:22:33 CET 2004

I got 
and under msys, i got /etc/fstab pointing to MinGW installation

I'm trying to build gmp-4.1.2.tar.gz,
after ./configure, and make, and a gamut of screen output, i'm
faced with

/bin/sh ../libtool --mode=link gcc  -g -O2 -fomit-frame-pointer -mcpu=athlon -march=athlon   -o   mp_bases.lo udiv.lo umul.lo add.lo add_1.lo add_n.lo sub.lo sub_1.lo sub_n.lo mul_1.lo
addmul_1.lo submul_1.lo lshift.lo rshift.lo dive_1.lo diveby3.lo divis.lo divrem.lo divrem_1.lo
divrem_2.lo fib2_ui.lo mod_1.lo mod_34lsub1.lo mode1o.lo dump.lo mul.lo mul_fft.lo mul_n.lo
mul_basecase.lo sqr_basecase.lo random.lo random2.lo pow_1.lo rootrem.lo sqrtrem.lo get_str.lo
set_str.lo scan0.lo scan1.lo popcount.lo hamdist.lo cmp.lo perfsqr.lo bdivmod.lo gcd_1.lo gcd.lo
gcdext.lo tdiv_qr.lo dc_divrem_n.lo sb_divrem_mn.lo jacbase.lo copyi.lo copyd.lo com_n.lo 
libtool: link: `mp_bases.lo' is not a valid libtool object
make[2]: *** [] Error 1
make[2]: Leaving directory `/cygdrive/c/new/gmp-4.1.2/mpn'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/cygdrive/c/new/gmp-4.1.2'

There is no mp_bases.lo file.
There is mp_bases..lo and it's empty, and there is a mp_bases..o and its not empty.

Where do I look to fix whatever is wrong?
Do you guys need more input
(like the output of config.log, and make output up until the error)?

I searched the archives, but couldn't find anything relevant
(and googling for the error messages brings up endless libtool files).

Do you Yahoo!?
Yahoo! Mail - More reliable, more storage, less spam

More information about the gmp-discuss mailing list