compiling on sparc

Dennis Lubert plasmahh at
Thu Jul 22 22:12:28 CEST 2004

At 21:54 22.07.2004, you wrote:
>On Thu, 22 Jul 2004 21:27:52 +0200
>Dennis Lubert <plasmahh at> wrote:
> > Hello,
> >
> > I have tried to compile gmp 4.1.3 with a gcc 3.3.4 on a Sun Blade 100
> > running SunOS 5.9.
> > After I resolved the problems and ran configure with ABI=32 I noticed
> > that not copyi.o was compiled, and later I got many undefined symbol
> > errors to __gmpn_copyi. So where is the appropriate place to look why
> > this file is not compiled ? or is there already a known fix ?
>I am not sure why you are seeing this, but what compiler switches are
>you using?  Do you want 32-bit only?

No, I would like to have 64 but it does not work, with 4.1.3 I still get 
this error :
I tried to add -fPIC to CFLAGS for configure, but then the compiling breaks 
with some error about requesting sparclight ...

I dont use any special options now, just run
ABI=32 ./configure

and then the needed file and function is not created.

>BTW, I have a pkg named libgmp that includes several sparc libraries for
>Solaris 8 and Solaris 9 on  The pkg was built using Sun's

Problem is, its not my system, so I run stuff in my homedir, and I dont 
have much experience with solaris. If you can tell me how to do it with the 
sun compiler (Sun C 5.5 2003/03/12 installed here) it would be nice. My 
final goal is to get rid of the bus error when using gmp, so I tried to use 
4.1.3 (4.reallyold installed here)


Carpe quod tibi datum est 

More information about the gmp-discuss mailing list