swox pgp keys

Niels Möller nisse@lysator.liu.se
08 Jan 2003 21:29:04 +0100

Torbjorn Granlund <tege@swox.com> writes:

> Well, of course I should sign it.  Unfortunately, I used pgp
> to generate my keys, which we no longer have installed.  I
> have tried using gpg 1.2.1, but I cannot get that to work
> properly.

Perhaps gpg still has problems with rsa keys that aren't "sign-only".
Sad that this still is a mess.

> 1) First imported my pgp keys.  When trying to sign with
>    gpg, it then insisted on using IDEA which our gpg build
>    does not support.

That's really strange. No encryption algorithm should be involved when
you only sign a key. I.e.

Hmm, or perhaps your private key is encrypted using IDEA? That would
kind-of make sense. That's sounds like it would explain it.

> 2) Attemtped to generate new gpg keys.  It hangs forever,
>    saying it needs 300 more bytes.  It doesn't seem to accept
>    keyborad input for more entropy.

Try running on a machine with /dev/random. I've not seen that problem,
but I've only tried gpg key generation on linux and some version of
Solaris. What kind of key would you need to generate?

You probably need to

  1. Either reinstall pgp, or get the idea add-on for gpg (at least I
     think there exists such a thing).

  2. Use the "change passphrase" feature to encrypt your key using
     some non-patented algorithm instead of idea, or use the to sign a
     new key generated by gpg.

  3. Forget about your old key and generate a new one. In order to
     verify the gmp signature, I'd need to exchange keys either with
     you or with some of the other people that have signed the swox
     key (rom, mkoya, linus and ilja).