gcd_11 asm

Marco Bodrato bodrato at mail.dm.unipi.it
Sat Aug 24 14:54:46 UTC 2019


Il Sab, 24 Agosto 2019 12:14 am, Torbjörn Granlund ha scritto:
> "Marco Bodrato" <bodrato at mail.dm.unipi.it> writes:

>   It is not elegant, I agree, but maybe joining them both in a single
>   .asm file, so that the jump is local?
> We might do that, but it makes things a lot more complicated as there

The mpn_gcd_11_for_gcd_22 entry point proposed by Niels is much more
elegant than my workaround...

>   Even if... maybe I'd call them _1o1o and _2o2o, as someone suggested :-)
> Do you want an entry point also for _22 which accepts even operand(s)?

No, but I usually like a little bit of coherence in the naming convetions,
so that I do more easily remember the exceptions in the calling
conventions :-)


More information about the gmp-devel mailing list