Torbjörn Granlund tg at gmplib.org
Thu Aug 15 19:21:18 UTC 2019

nisse at lysator.liu.se (Niels Möller) writes:

  Attached is a patch to move the current (slow) gcd_2 to a separate file, rename
  it mpn_gcd_22, change argument and return type, and add a basic test.


  Do you agree with the naming in 

  typedef struct
    mp_limb_t d0, d1;
  } mp_double_limb_t;

  or should it be something else?

That's a good name.  (I doubt we will need structs for 3 and 4 limbs, so
we don't need a fancier naming scheme.)

  Next would be speed support, and then it's easier to try ways to make it

Speed support would be very welcome!

Please encrypt, key id 0xC8601622

More information about the gmp-devel mailing list