Update THESHOLD name in jacobi.c
nisse at lysator.liu.se
Tue Apr 16 20:13:02 UTC 2019
Seth Troisi <braintwo at gmail.com> writes:
> Per Niels' suggestion I'm taking a look at the Jacobi documentation.
Algorithm description was most recently posted here:
> I noticed that jacobi.c aliases GCD_DC_THRESHOLD then uses both names once.
I agree it should be JACOBI_DC_THRESHOLD at both places. This makes it
possible (but optional) to use a separaately tuned jacobi threshold.
Which is unlikely to make much difference. The use of mpn_hgcd2_jacobi
rather than mpn_hgcd2 implies a *sligthly* larger constant for the linear
part of the work.
Niels Möller. PGP-encrypted email is preferred. Keyid 368C6677.
Internet email is subject to wholesale government surveillance.
More information about the gmp-devel