_basecase or _sec? [Was: GMP symbol naming (and the history thereof)?]

bodrato at mail.dm.unipi.it bodrato at mail.dm.unipi.it
Sun Mar 3 20:56:12 CET 2013


Il Dom, 3 Marzo 2013 5:53 pm, Torbjorn Granlund ha scritto:
> nisse at lysator.liu.se (Niels Möller) writes:
>   > __gmpn_sqr_basecase
>   This (and also mul_basecase) should be public. They're useful for crypto
>   applications where numbers are known to be of moderate size and where
>   low code complexity is desired.
> I agree.  Should we consider a name change?  What about publishing
> mullo_basecase?

Uhm... Why are all this _basecase functions needed? To have them running
in predictable time (only dependent on sizes, not on actual operands)? If
this is the reason, let's call them _sec.


More information about the gmp-devel mailing list