Status update: mini-gmp

Niels Möller nisse at
Thu Feb 16 12:23:33 CET 2012

Torbjorn Granlund <tg at> writes:

> Perhaps a better name would be bootstrap.c?

Makes some sense. At least it's shorter.

> I suppose that's not a truly necessary tweak.  Using the strategy of
> including bootstrap.c/mini-gmp-extra.c in all files might be a bit
> cleaner.

Depends on whether or not we aim to eliminate that extra file and only
use mini-gmp.c. If not, then I agree it's a bit cleaner to include the
bootstrap.c file everywhere, and then we can also be less zealous about
moving definitions out from that file.

And one correction, I wrote:

>   In mini-gmp-extra.c, I defined xmalloc as an alias for
>   gmp_default_xalloc, an internal function in mini-gmp.c, rather than
>   including yet another copy of the same thing.

I think that's a sensible thing to do, but that change wasn't actually
included in the posted patch.


Niels Möller. PGP-encrypted email is preferred. Keyid C0B98E26.
Internet email is subject to wholesale government surveillance.

More information about the gmp-devel mailing list