Fail 1 test with GCC-5.2

Torbjörn Granlund tg at
Thu Oct 15 17:23:45 UTC 2015

Leif Leonhardy <not.really at> writes:

  Will these reports ever end? ;-)
  I bet he tried to compile GMP 4.3.2 (with GCC 5.2).
  Oscar, please use a recent version of GMP;  the test suite (i.e.,
  t-scan) of the completely outdated GMP 4.3.2 contains a subtle bug such
  that it'll fail with any GCC version >= 4.8.0.  It has been fixed years
  ago, but the GCC guys still "recommend" that dead old, version.  (More
  precisely, GCC's prerequisites page says "GMP 4.3.2 *or later*", but
  their "GCC infrastructure" folder still only offers that version, dated
  February 1st, 2010(!).  While it is indeed sufficient to /bootstrap
  GCC/, and the library itself isn't affected by the bug, you'll certainly
  want to use a more current one.)
We might try to convince the FSF to remove all GMP versions older than
5.0, since we have not been able to resolve the situation with GCC's
download scripts.


Please encrypt, key id 0xC8601622

More information about the gmp-bugs mailing list